RStudio no longer loads script files

After a crash RStudio project no longer opens with the script files last used. I have tried creating a new project, opening scripts and saving workspace but same problem. Also updated to latest version of RStudio. Any suggestions would be appreciated as finding this very inconvenient as working with several different projects

Tools -> Global Options -> "General" tab -> Check "Restore previously open source documents at startup"

1 Like

Thanks, yes I had checked that and it was ticked. Older projects still open with their documents, but new ones and the one that had a crash do not

I created a new RStudio-Desktop directory in Users\Geoff\AppData\Local, by renaming the original directory to see if this fixed the problem as assume this is where the document history is stored. It didn't work but I note that several of the files are empty after a trial run of RStudio. It looks as if RStudio is not writing these files, any suggestions please.

Unfortunately, I don't have any suggestions. What I can tell is that similar things happened to me too. The only difference is that for just 1 project some of the keyboard shortcuts stopped working. I didn't find a reason or solution for that.

I have the exact same problem. Of course the option is checked. I have tried re-installing R Studio twice with no success. The problem persists.

Have you find a solution so far, Glp? This really disrupts the workflow.

No, I have tried everything I can think of, but no improvement. It still works successfully on a different computer with the same project files (copied via OneDrive, but on a local hard drive), so assume there is something wrong in the Registry, but don't know sufficient to risk messing around with that.

This is too bad, It really reduces the utility of r-studio. It would be great if someone from the Rstudio team would join this conversation.

I also raised this issue on GitHub .

As a relative R novice I am not clear where topics such as this should be raised !