RStudio: menu items, commands, no response after installation.

After installing R and RStudio on a Windows 10 computer:

  • Running RGui works fijne.
  • RStudio runs and finds the version of R installed.
  • Clicking on menu items, etc. is possible.

However, there is no response to opening any menu item or typing any command (e.g. help(), demo()) in the console. Also, it will not close gracefully; it must be killed in the process list.

Any ideas?

Thanks in advance.

Richard Thomas

Hi, welcome!

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

Hi and thank you for your suggestion!

Unfortunately, it did not help. I even uninstalled and reinstalled R and RStudio to no good effect.

You can also try resetting RStudio's state:

Good idea. I just tried that. It made no difference, unfortunately. :frowning:

Thanks for the suggestion!

I'm also having the exact same issue.


As a last resort, you can also try uninstalling and reinstalling both R and RStudio.

If that still doesn't work, the only other guess I have is that this could be related to some other software installed and running on the machine that is somehow interfering with RStudio's normal processing. Some examples we've seen before:

It could be worth investigating whether closing some of the other software on your machine makes a difference.

Thanks for your response. I have tried uninstalling and reinstalling, no help. It's probably related to something that's installed on my computer, as I've heard of others in my company with the same issue.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.