RStudio launches with just a blank screen or unable to connect to localhost error

Everything was working fine until I tried to test the new features in the Preview release in Rstudio. I installed the latest version and everything was working fine until it restarted and I started getting an unable to connect to localhost error. I tried reverting back to Rstudio 1.1 stable release and I'm getting a blank white screen. I have tried reinstalling R/Rstudio mutliple times and resetting state as advices and have gone over the forums but I'm unable to get a resolution. While running the diagnostics report this is what I get -

R session launched, attempting to connect on port 33243...
15 Oct 2018 06:23:28 [rsession-alexjoseph] ERROR Unexpected exception: call to empty rstudio_boost::function; LOGGED FROM: void rstudio::r::session::RCleanUp(SA_TYPE, int, int) /Users/vagrant/workspace/IDE/macos/src/cpp/r/session/RStdCallbacks.cpp:712

I'm completely stuck and out of ideas, any help would be appreciated

For the weirdest reason - This started working when I reverted to a previous version of R. Closing now.