Rstudio latest version 2023-10-17 cannot find Quarto, create Quarto file, Render Quarto file

Note: I have installed library(rmarkdown)
After I updated RStudio to the latest version, I can no longer create a Quarto file (window pop out says: cannot find the specified program)
Thus, I installed Quarto by downloading it from the website.
I copy other Quarto files to write a new one, but when I render it, it gives error 123 immediately: (translated into English as: Error: The file name, directory name, or tagline method is incorrect)

I have tried uninstallation and re-download and re-installation of RStudio, but it does not work. Theoretically, I should not install Quarto separately, so I have uninstalled it. Nothing changed, except the directory of the Quarto in the error.

Please help me out! Many of my assignments and projects need Quarto rendering. Thanks!

I do not know if this will help or not but can you copy and paste your file and the error messages here. It is easy to miss things in a screen shot.

BTW, I "think" you need to install Quarto independently outside of R.

Thanks! I have solved the issue. The problem seems like I added a file to set the Temp dir when I install R, in order to solve the error "Temp dir contains space". With that file, I successfully loaded R4.2.3 in RStudio. Now, to solve this Quarto issue, I removed that SITE file, and R still can run in RStudio, while Quarto works fine.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.