Rstudio keeps flashing after fedora 35 update

Dear all,

I have updated my system to fedora 35 and immediately after start-up my screen starts flashing after I interact with Rstudio (scrolling, typingl selecting, ...). Sometimes the screen remains blank for a second. I can end the session in a regular way.

My terminal shows the following (harmless?) warnings:

libpng warning: iCCP: known incorrect sRGB profile
QXcbClipboard: SelectionRequest too old

The set-up of my system:

R version 4.1.2 (2021-11-01)
Platform: x86_64-redhat-linux-gnu (64-bit)
Running under: Fedora Linux 35 (Workstation Edition)

Matrix products: default
BLAS/LAPACK: /usr/lib64/

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C              
 [3] LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [7] LC_PAPER=en_US.UTF-8       LC_NAME=C                 
 [9] LC_ADDRESS=C               LC_TELEPHONE=C            

I have tried the following, but these did not help

  1. reinstalling
  2. start cmd line with --no-sandbox
  3. changing the rendering options in the general advanced options; changing it to software even resulted in a blank unresponsive window.

Any thoughts or suggestions would be very welcome.


I would try and see if disabling GPU rendering (and using software rendering instead) helps to stabilize the IDE (cf. by manually starting the IDE like below:

export RSTUDIO_CHROMIUM_ARGUMENTS="--disable-gpu"

Thanks for the suggestion. I tried this and unfortunately it did not help.

Sorry to hear that this is still not working.

I did some more tests on my local f35 machine and once I disabled the sandbox (rstudio --no-sandbox or setting RSTUDIO_CHROMIUM_ARGUMENTS="--no-sandbox" in your shell profile) I at least could start rstudio successfully.

Unfortunately I cannot reproduce the flashing behaviour that you observe. Also din't get the libpng and QXcbClipboard messages but got some warnings about rstudio ignoring some wayland settings.

I am now wondering:

  • which R Studio version are you using ?
  • what graphics card and driver do you use ?
  • which window manager do you use ?

Also - maybe it would be worth to move ~/.config/rstudio and ~/.local/share/rstudio out of the way for a moment to ensure you don't have any left-over legacy configuration in there (cf. ?

@ruth.seurinck another option would be to check-out the Fedora 35 native solution and install "their" rstudio ide which is available as "rstudio-desktop". The version is exactly the same than you get from rstudio but it is purpose compiled against the fedora OS packages. On my Fedora 35 box this rstudio works flawlessly without a single workaround.

I've encountered the same issue on Manjaro after a recent system update (update to Manjaro 21.2.1), using RStudio official binaries.
I've opened a separate thread but just wanted to add that doing this

maybe it would be worth to move ~/.config/rstudio and ~/.local/share/rstudio out of the way for a moment to ensure you don't have any left-over legacy configuration in there

didn't help. On the other hand, changing to software rendering seems to have solved the problem for me.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.