RStudio is not working(responsive but no output)

My R studio is not being very responsive. For example, if I run norm(10) in the terminal - I do not get the output. I also do not see the terminal being busy.

When I try to restart R session with Ctrl + Shift + 10 I see the Quitting R session label showing up at the top, but nothing happens no matter how long I wait.

Also, nothing shows up when I click on any menu item. For example, if I click on Tools > Global Options, the menu disappears the dialog window does not show up.

Here is a screenshot showing some of the problem,

I tried reinstalling R Studio and removing RStudio folder in AppData, but it did not improve the situation. Also, note that I can run RGui and run R commands outside of R Studio.

Can somebody help me with the situation?

Thank you!


Every time I started R studio I noticed it was doing something during startup and it would not stop.

So I deleted the %localappdata%\RStudio-Desktop folder and that solved the problem.

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

Thanks. I tried but it did not help. But I've found the solution!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.