rstudio is extremely slow even though I've install and uninstalled it for many times


I'm using Rstudio on MAC with OS 10.14.5. The Rstudio I'm using is the latest version.
Rstudio is becoming extremely slow, especially when saving and opening files. It seems like it's connecting to somewhere to complete that process. Sometimes it even said saving failed! Not sure whether it's the problem of stan files because every time I opened a stan file, it began to stuck. Have tried many solutions I could find online, but none of them worked. Really appreciate if you have any advice, thanks so much!

Hi there @lili27

That sounds pretty strange. I'm not a mac user but I cant imagine this being a common problem. Is it an old laptop? Maybe consider updating the Mac OS to 10.14.6 . You'r not using the RStudio Cloud version are you? Perhaps trying RStudio Cloud out and seeing if you have the same issues may give you a clue. How big is the Stan file? RStudio can handle them so it shouldn't have a major issue like your describing.

I also found the following from here that may be useful (personally I always use the latest RStudio Preview version too).

You can download the RStudio v1.2 Preview Release at

Thanks and good luck

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.