Rstudio is damaged

Hello, I am new to R and R studio. I was able to successfully download R on my MacBook, however when I try to download R studio I get the following error message "RStudio is damaged and cant be opened. You should eject the disk image". I have tried downloading multiple time via Firefox and safari, including restarting my computer. Any help would be greatly appreciated.


Hi, Ashley, and welcome.

I just re-downloaded the same file to my Macbook Air under Mojave without that message. My semi-informed guess is that the disk image was corrupted in transit, so my recommendation is to try it on a different internet connection, say at Starbucks.

Let everyone know if that solves the problem. And please report back if it doesn't!

Hi technocrat,

Thanks so much for the reply and the help. I tired your idea and attempted to download again while on a different WIFI network than my home, but unfortunately I keep getting the same network. Tried via firefox and safari :frowning:

That's mysterious, for sure, Ashley!

I can't tell if the instructions written in Chinese help. If they don't, I'll kick this up to RStudio support to see if they know of an issue related to this.

Thanks again! Yeah unfortunately the Chinese instructions were lost on me.

What version of macOS do you have installed on your machine?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.