RStudio installation problem on Windows 10

I was using the old version of R and RStudio on my Windows 10 Laptop and I was asked to update to the new version. I downloaded the new version and installed it with the new version of RStudio but when I try to open it, it shows me "Choose R installation" (RStudio requires an existing installation of R) while I already have an existing R installed.

Please help me on how to fix it.

No need to fix, it is just asking you to select the path to your installed Rlang. Because sometimes users might have installed several versions of Rlang, and the user will need to specify which version to use.

Thank you very much.

Can you help me with the steps on how to select the path?


I have tried to select the path of the new version of R and it does not work, but when I install the old version of R with the new version of RStudio, it asks me to choose an installation path for R which I did, and it works.
This shows that the new versions of R and RStudio will not work together.

Happy to hear that you've solved the problem, normally you just need to use the default settings, i.e. using system's default 64-bit version of R (of which the path is logged in the system environment) and select OK.
If you want any other version, you'll first need to select choose a specific version of R and click Browse to find the Rlang if it's not listed in the options, and then click OK.
I'm not sure about whether the latest Rstudio IDE works together with latest Rlang, I'm using R 4.3 and the Rstudio 2023.06 in win10, it worked just fine. Far as I can recall, Rstudio requires R version 3.3 and higher since one update, and the path problem never showed up to me.

This topic was automatically closed 42 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.