Rstudio Installation failing on Rocky Linux

I'm trying to get Rstudio running on Rocky Linux 9, having installed R without a problem.

I'm getting the following error report

R Session Startup Failure Report

RStudio Version

RStudio 2022.07.2+576, "Spotted Wakerobin" (e7373ef8, 2022-09-06) for RHEL 8

Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.8 Chrome/69.0.3497.128 Safari/537.36

Error message

[No error available]

Process Output

The R session exited with code 127.

Error output:

/usr/lib/rstudio/bin/rsession: error while loading shared libraries: cannot open shared object file: No such file or directory

Standard output:

[No output emitted]


Log File

[No logs available]

From the terminal where I tried to run it, I got the following:
TTY detected. Printing informational message about logging configuration. Logging configuration loaded from '/etc/rstudio/logging.conf'. Logging to '/home/jim/.local/share/rstudio/log/rdesktop.log'.
Warning: Ignoring XDG_SESSION_TYPE=wayland on Gnome. Use QT_QPA_PLATFORM=wayland to run on Wayland anyway.
"Uncaught TypeError: Cannot read property 'notifyRCrashed' of undefined"

Any ideas?

you need openssl. install it from a terminal and then verify you have the crypto lib by
find /usr -name
that is your problem based on the error.

We don't have official Rocky Linux 9 binaries, but we are about to release a version that has Rocky Linux 9 support as a preview. Give it a spin and let us know if it works for you!

This has worked for me, thanks so much!

1 Like

Great, glad to hear it!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.