RStudio IDE crashes when browsing files

Crash Information:

Description of crash - RStudio IDE crashes whenever I browse files from my computer in a dialog box (the Files panel in the IDE works). That means I can't save anything. I have seen many posts on this forum about a similar issue that was caused by synching cloud files like OneDrive, but there hasn't been any since a couple of years and it seems like that issue was fixed in past updates. I still tried quitting Dropbox and OneDrive, still doesn't solve the issue.

Steps to reproduce -

Type Ctrl+O to open a window to browse files OR Ctrl+S to save a file -> The window opens, then everything crashes after ~2 seconds, no error message.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 2022.02.0+443
  • OS Version: Windows 10 x64 (build 19044)
  • R Version: 4.1.2 (2021-11-01)
  • Your sessionInfo():
    R version 4.1.2 (2021-11-01)
    Platform: i386-w64-mingw32/i386 (32-bit)
    Running under: Windows 10 x64 (build 19044)
    Matrix products: default
    [1] LC_COLLATE=English_Canada.1252 LC_CTYPE=English_Canada.1252
    [3] LC_MONETARY=English_Canada.1252 LC_NUMERIC=C
    [5] LC_TIME=English_Canada.1252
    attached base packages:
    [1] stats graphics grDevices utils datasets methods base
    loaded via a namespace (and not attached):
    [1] compiler_4.1.2 tools_4.1.2

Crash Report:

I don't see how to generate one for windows :frowning:


  • RStudio diagnostics report:
    In the log, I have many times the following entry:

2022-05-19T18:40:30.218742Z [rsession-Laurie] ERROR CLIENT EXCEPTION (rsession-Laurie): (TypeError) : Cannot read property 'O' of null;|||org/rstudio/studio/client/workbench/views/source/editors/text/|||org/rstudio/studio/client/workbench/views/source/editors/text/|||org/rstudio/studio/client/workbench/views/source/editors/text/|||com/google/gwt/core/client/impl/|||com/google/gwt/core/client/impl/|||com/google/gwt/core/client/impl/|||rstudio-0.js#-1::eval|||com/google/gwt/cell/client/|||Client-ID: 33e600bb-c1b1-46bf-b562-ab5cba070b0e|||User-Agent: Mozilla/5.0 (Windows NT 10.0 Win64 x64) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.8 Chrome/69.0.3497.128 Safari/537.36

And got once this entry:

2022-05-19T18:40:20.483329Z [rsession-Laurie] ERROR system error 22 (The device does not recognize the command); OCCURRED AT class rstudio::core::Error __cdecl rstudio::core::crash_handler::initialize(enum rstudio::core::crash_handler::ProgramMode) src/cpp/core/CrashHandler.cpp:358; LOGGED FROM: int __cdecl main(int,char *const [ ]) C:\Users\jenkins\workspace\ide\open-source-pipeline\prairie-trillium\src\cpp\session\SessionMain.cpp:1919

From Troubleshooting Guide: RStudio Crashed

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.