RStudio IDE crashes after running a GARCH(1,1)-simulation with Stan (rstan) on Windows 10

Crash Information:

Description of crash -

Hi, all,

I have recently upgraded my R version on a Windows 10 machine from 3.6.0 to 4.1.0. I am a frequent user of Stan (rstan). In particular I have a working GARCH(1,1)-code for time series simulations from which worked well before. I keep on increasing the amount of empirical data available on the input list. After the ugrade of R to version 4.1.0 my R sessions with the Stan-GARCH(1,1)-code on RStudio invariably crash, for no apparent reason, independent of the notebook (equipped with Windows 10) on which I run the R session. Some help in this matter would be much appreciated.

Many thanks.

Cheers, Henk

Steps to reproduce -

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 1.4.1103
  • OS Version: Windows 10, Version 21H1
  • R Version: 4.1.0
  • Your sessionInfo(): Impossible to provide as session crashed. Cf. screenshot appended.

Crash Report:

Impossible to provide as session crashed. Cf. screenshot appended.


Screenshot appended.

From Troubleshooting Guide: RStudio Crashed

RStudio 1.4.1717 is recommended for R 4.1. It is the latest release version.

Hi, @EconProf , many thanks for your suggestion to upgrade RStudio to version 1.4.1717. Having done so, my 1930-lines-*.Rmd-code continues crashing when the GARCH(1,1)-simulation with rstan is to be run with a Student-t-likelihood. I will isolate this simulation in order to identify the cause for this problem. Cheers.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.