RStudio googlesheets error C stack usage too close to the limit

I am working on linking my googlesheets to RStudio, but getting an error when trying to list the avaliable googlesheets. (On MacOS)

gs_auth(new_user = TRUE)
Error: C stack usage 7969952 is too close to the limit

I have tried increasing the C stack usage limit through the Mac terminal, but it still runs the same error when I have tried it again. I am using the newest versions of R and RStudio.

What's the output of Cstack_info() for you when you run it in R?

This Stack Overflow thread has some suggestions:

When I run Stack_info() in R, it gives this:

size current direction eval_depth
7969177 11824 1 2

I've looked at that thread, and it suggests to increase the stack usage before opening R which I have tried but didn't seem to work.

Have you tried running this on just a subfolder (with, presumably, fewer files)?

Yeah, i've tried this too! and tried linking it to a google account with only one spreadsheet in and it still gave me the same error.

Are you in a fresh R session? See, for example, the recommendations in this thread:

Hi all,

I have the same problem. Rebooting my instance, cleaning my workspace and restarting my session did not help. The problem started to appear 5 days ago. Before it worked without problems.

I reinstalled the package with all dependencies, but did not see any changes.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.