RStudio Github Deployment

Hello, in trying to set up github content deployment on Connect I'm getting the following error. We are using a private repo and credentials have been setup in the config file but the error is the same on private or public repos. When I run the git command in the error I always see the SHA for the manifest.json, so is it something in there perhaps? Using Connect v1.8.16 to rsconnect::Writemanifest() and have tried a more explicit

rsconnect::writeManifest(appFiles = c("xx.Rmd",'helpers.R"),appPrimaryDoc = "xx.Rmd")

Here's the error:

RStudio Connect could not find available branches. 
Click "Back" to enter another repository URL.

Scanning returned the error:

Error: expected 2 entries in line but found 1: arguments: 
/usr/bin/git ls-remote --quiet --refs --heads

Working on the assumption that you've configured your Connect config file correctly (according to instructions, and your config file looks similar to this:

; /etc/rstudio-connect/rstudio-connect.gcfg
Host =
Username = accountName
Password = <encrypted-string>
Protocol = https

I'm going to hazard a guess that one of the following might be the cause:

  • You haven't added the accountName to the github repo. (In other words, in github, this use must be able to at least read the repo
  • The password encryption string is incorrect
  • Or there is some other networking problem that prevents Connect from seeing github

Hi Andrie,

Thanks for the speedy reply. I used rscadmin to generate the encrypted github password on the Connect linux server and then pasted it into the config file in the format you outline. When I run the following command on the server I do get a reply from github with the SHA of the manifest.json after supplying the same username and password,
/usr/bin/git ls-remote --quiet --refs --heads Also, temporarily changing the repo to public produces the same error, so I assumed that ruled out authentication issues.

Here's the git response on the linux server:
[~@~ ~]$ /usr/bin/git ls-remote --quiet --refs --heads
Username for '':
Password for '':
72e410f4509600398ed015d4c4995936d4e28a50 refs/heads/master

Just chiming in here to say that this might be worth shooting across to so we can help you fix within our professional support!

If you can share a link to this community post, along with a diagnostic bundle, that will help us address the issue as quickly as possible!