RStudio freezing since upgrade to macOS Catalina

Since updating my OS to the latest mac version (Catalina 10.15.3), RStudio keeps freezing at seemingly random points in time (sometimes after a few minutes, sometimes after a few days).

I can still edit scripts, but I can not save any scripts or run any commands in the console. The command will just hang, like it's working, except it never ends and there is no "stop sign" indicating it is working.
At that point the only wait to quit is by force quitting the process and Rstudio will only work again if I reset the state by deleting the .rstudio-desktop directory as explained here:

I've already reinstalled both R and Rstudio to no avail. This is now happening at least every couple days, please HELP!

R version 3.6.3 (2020-02-29)
RStudio version 1.2.5033

1 Like

I'm on your install except, I haven't yet gone 3.6.3. I'll try, using the notarized version, which I suspect is the culprit.

No dire disasters so far, and I'm able to save edits. Did you have this problem before 3.6.3, which only came out on 2020-03-29? I now think it may be the non-sandboxed version of 3.6.3 that's the trouble.

oh, and btw, welcome!

Please see the FAQ: What's a reproducible example (`reprex`) and how do I do one? Using a reprex, complete with representative data will attract quicker and more answers. This one, of course, doesn't require one.

Thanks for looking into this.
it happened after updating the OS but before updating R if I remember correctly, as I think I updated R and Rstudio in an attempt to fix this! The R version I downloaded was released on 29/02 however (not 29/03 like yours): I'm not seeing another more recent version there though.

It's happened again this afternoon. Quite frustrating.

Frustrating. Did you install the notarized version?

yes I did, everything really works fine until it just hangs randomly.

Have you tried changing to "software rendering"?

1 Like

no I have not tried that yet. Why do you reckon this would help?
happy to try it though, I'll give that a go and report back if it helps.

FWIW, I have the configuration shown in @andresrcs screenshot on a MacBook Air 2015 version without problems so far. But graphics drivers could, of course cause things to go blooey, to use the technical term.

1 Like

don't want to jinx it but so far so good with the software rendering, no crashes. :crossed_fingers: :crossed_fingers: :crossed_fingers:
I have a macbook pro 2016 so yes I'm guessing there might be some differences graphics-wize with your set up @technocrat .

1 Like

Great. Please mark the solution for the benefit of those to follow if your luck continues to hold!

yes, I'm going to give it a couple days to make sure this holds and I'll mark it then.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.