RStudio freezes after trying to change the spellchecker language

Dear All,

While changing the language of the spellchecker, RStudio became frozen. Subsequently, I killed RStudio with

killall rstudio

However, whenever I start RStudio, it opens up, but again looks frozen and every mouse click seems to be ignored.

I have even removed my


folder, but, as soon as I open a new script window, the problem returns.

I am not sure whether the following is related, but before I tried to change the spellchecker language, I had installed synamyn:

I am using:


on Fedora Linux 33.

Could you please help me?

Thanks in advance!

I suspect that the problem may be related with


as it is using a lot of CPU in spite of the fact that RStudio is now not doing anything.

Again, thanks,


You might want to try using software rendering instead:

Thanks, Kevin. I had already tried using software rendering instead but with no success.

The problem occurs whenever one tries to change the spell-checker language and clicks Apply instead of OK. Clicking on OK, no freezing occurs.

For others who may get into the same freezing problem, the way out is to remove the following folders:



(please, notice that these are distinct folders, at least on Linux).

The cause of the reported problem is not related to synamyn, as now everything is working fine and synamyn remains installed.


This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.