RStudio - Fatal Error Occurred and not processing


There was a thread with an identical problem to what I have now back in December but has been closed for no responses after 21 days: RStudio - Fatal Error Occurred and now I can't process anything

I'm having an identical issue where I open RStudio and within 10s it throws up the "fatal error" message. I have restarted my computer, reinstalled RStudio entirely, and cleared my default working directory of any R related environment files (.Rhistory or .Rdata) and am still getting the message. I'm pretty stuck at this point so any suggestions very much welcomed!


Let's rule out the most common sources of problems

Have you tried resetting RStudio's state?

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

Have you checked the content of your or any .Rprofile file that you might have? Code executed at startup might be breaking your R session.

Ah fab, resetting the RStudio state worked for me - I hadn't thought to do that, thanks very much!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.