RStudio fails to start up after update to latest version and update of R to 4.2.2

Error Information:

Nothing visible
Description of issue -
Updated R and Rstudio after not using it since 2017 (although that version worked)
R Works OK
RStudio fires up icon then immediately fails with a segmentation fault

Attempted steps taken to fix -
Deleted all RStudio files and then re-downloaded RStudio .

System Information:

  • RStudio Edition: (Desktop or Server) Desktop
  • RStudio Version: 2022.07.2+576
  • OS Version: MaCOS 10.15.3
  • R Version: 4.2.2
  • Output your diagnostics report (if possible):
    No diagnostics report created.
    Terminal output:
    Last login: Tue Nov 29 15:21:37 on ttys000
    (base) lesormonde@unknown787b8ab27c43 ~ % /Applications/ --run-diagnostics
    zsh: segmentation fault /Applications/ --run-diagnostics
    (base) lesormonde@unknown787b8ab27c43 ~ %

From RStudio Desktop Will Not Start on

Catalina is no longer supported by Apple, and RStudio only supports macOS versions that are supported. If upgrading OS isn’t feasible, it may be possible to down version RStudio, but that might also require down versioning R.

This web page: RStudio Desktop - Posit indicates that RSTudio works with "10.15 +" which is why I went ahead with the download.

Is the web site wrong?

I’ll recheck. Either the page hasn’t been updated yet or I’m wrong (again).

Catalina's last security update was in July 2022, while Big Sur and Monterey had updates in September and October. As of November, Catalina was officially off the supported list. Updating is probably a good idea even if RStudio was working on Catalina.

Surprisingly hard to track down the definitive answer I thought I once saw. Here's what I think

  1. Apple supports its current release and the two previous
  2. Ventura was recently released, therefore, Catalina is dropped
  3. Wake Robin was released before Ventura
  4. Even so, RStudio github contributors are recommending OS upgrade for Wake Robbin problems on Catalina

My own practice is to upgrade to the latest OS after the first point release, and I try to stay within a couple of point releases on R, except when there is a big deal like 4.1 introducing |> . I don't worry too much about RStudio until I run across a problem or notice some new feature being discussed.

There are a lot more invisible moving parts for the dance among OS, R and RStudio that are obvious to users than we realize. The ghosts in the machine can waken when some alignment of machine states occur that creates an overlooked edge case.

Unless it will break something that you rely on, my advice is to do the upgrade if your hardware supports it. As an alternative, if your hardware has the resources, you can install a virtual RStudio Server running under Ubuntu in the background and get much the same experience through the regular OS as you would have using the desktop IDE. Not for the faint of heart, but doable.

OK. Will upgrade in the near future.
Last time I upgraded, it destroyed my machine. It had to go back to the shop for 2 weeks, hence my reluctance to upgrade unless absolutely necessary. It seems I have reached the point where I cant put it off any longer.
Many thanks for your help.

1 Like

Good luck. I’m still sore that Apple stopped supporting my tower after Snow Leopard

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.