Rstudio fails to launch R session at startup in Fedora

Error Information:

Description of issue -
I am able to launch Rstudio only from the terminal with sudo. A command from the GUI will have RStudio hanging (white screen, no interface get loaded).
The problem seems to be related to launching an R session because if I launch a "top" command I only see the process rsession. I am unable to exit RStudio from the guy if I do not kill the rsession process first from the terminal.

Attempted steps taken to fix -
I tried the common steps described here:

System Information:

  • RStudio Edition: (Desktop or Server) desktop
  • RStudio Version: RStudio 2021.09.1+372, "Ghost Orchid" (8b9ced18, 2021-11-08) for CentOS 8
  • OS Version: Fedora 35
  • R Version: 4.1.1
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on

I forgot to add that the behavior showed up after updating to Fedora 35.

It sounds like you're hitting this issue: Blank window in Fedora 35 · Issue #10072 · rstudio/rstudio · GitHub

I uninstalled both R and RStudio. Today Fedora pushed a large update, I reinstalled everything and now it works. Go figure. Thanks a lot for your help.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.