Rstudio - extremely slow with Stan files

I am having problems on my M2 MacBook Pro when I have Stan files open in the IDE. When having a .stan file open in the IDE everything becomes extremely slow, take a few minutes to save the Stan file, takes minutes to save a .R file, loading files, saving anything. It has become practically unusable. I have tried uninstalling R, uninstalling Rstudio, reinstalling both, tried the most recent versions, tried older versions. I even did an entire clean install of my OS to see if that was a problem. The problem still persists.

I do not seem to have this problem on my older intel based Macs.

Hi, not sure if this will help, but maybe you could try CmdStanR:

CmdStanR (Command Stan R) is a lightweight interface to Stan for R users that provides an alternative to the traditional RStan interface. See the Comparison with RStan section later in this vignette for more details on how the two interfaces differ.

Getting started with CmdStanR • cmdstanr (

Not sure that cmdStanR really helps. When you look at the Stan website they suggest rstudio because of the Stan file support.

This problem is really frustrating and I am not sure what else to look at to see what the problem is. This wasn’t happening before September 2023.

Rstan's official issues tracker can be found at Issues · stan-dev/rstan · GitHub
I imagine that they will ask for some sort of reproducibe example.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.