RStudio error message when using library(patternize) and library(imager)

I am attempting to use the library functions library (patternize) and library (imager) in RStudio, but when I run it this is what I get:


> library(patternize)
Warning message:
*package ‘patternize’ was built under R version 4.1.2 *
> library(imager)
Loading required package: magrittr

Attaching package: ‘imager’

The following object is masked from ‘package:magrittr’:

  • add*

The following objects are masked from ‘package:stats’:

  • convolve, spectrum*

The following object is masked from ‘package:graphics’:

  • frame*

The following object is masked from ‘package:base’:

  • save.image*

Warning message:
package ‘imager’ was built under R version 4.1.2

At this point I have uninstalled R Studio and redownloaded it several times. It is in the Applications folder, and I have tried running updates on both the packages and the RStudio app itself, so I am unsure at this time how to resolve this error code
I am very much a beginner in R Studio, and would appreciate it if anyone has a suggestion!

This is not an error message, it is just a warning letting you know that the binary packages you have installed have been compiled for a slightly different R version than the one you are currently using.

Have in mind that RStudio is an IDE for the R programming language but it doesn't come with R bundled so they can have independent versions, very likely you want to update R not RStudio.

Also, after updating R, it is good practice to update your packages with the checkBuilt option.

update.packages(checkBuilt = TRUE)

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.