RStudio doesn't start in linux slackware

Hi RStudio development team!

I'm having problems running Rstudio. In my job I run a system that involves MikTex, R, Rstudio and spreadsheets. Well, I managed to install all of those successfully, with no errors or warnings. However, when I try to run Rstudio, it aborts, never opens.

When I run it in terminal, it gives me the following error:

bash-5.1# rstudio
Segmentation fault

I saw elsewhere that it could be a problem with video driver, and a possible solution would be


However, it didn't worked either...

When I run strace rstudio, the log shows the following error:
--- SIGSEGV {si_signo=SIGSEGV, si_code=SEGV_MAPERR, si_addr=0x1c} ---
+++ killed by SIGSEGV +++
Segmentation fault

My system is:

  • Slackware-current

  • VGA compatible controller: Intel Corporation HD Graphics 620 (rev 07) (prog-if 00)

  • R-4.0.0-x86_64-1_SBo

  • Rstudio version: rstudio-desktop-1.1.463-x86_64-1_SBo
    (I've tried many versions of RStudio, all with the same error, never passing the startup)

I was advised to change the file ~/.config/RStudio/desktop.ini with this:

$ cat ~/.config/RStudio/desktop.ini

However, I've noticed that I don't have this folder in my root tree, and I can't disable hardware acceleration.

Well, that's it... Someone could help me with this issue?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.