RStudio doesn't start after Update OS, R, and RStudio on Mac

Error Information:

Description of issue - After updating my OS and downloading the newest versions of R and RStudio, RStudio does not open.

Attempted steps taken to fix - I attempted to update R recently but couldn't on the OS I was running, so I first updated the OS (now on Monterey 12.6.1), then downloaded the newest version of R (my laptop is a mid-2015 MacBook Pro with 2.2GHz Quad-Core Intel Core i7 processor, so I opted for R-4.2.2.pkg rather than R-4.2.2-arm64.pkg). I then got a message in RStudio that made me think it was too old to be compatible with the new R version, so I tried to update that as well. It did not work, so I deleted RStudio and tried to re-download the most recent version (2022.07.2). It appeared to work, but will not actually open. I have tried uninstalling and re-downloading both R and RStudio, restarting the computer, waiting longer before I click RStudio icon to open... No luck. I also tried a couple earlier versions of RStudio and had the same problem (2022.07.01, 1.4.1743, 1.3.1093). I'm wondering if I'm trying to download things that aren't compatible with this Mac? Any help is appreciated!

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 2022.07.2-576
  • OS Version: MacOS Monterey 12.6.1
  • R Version: 4.2.2 (2022-10-31) -- "Innocent and Trusting"
    x86_64-apple-darwin17.0 (64-bit)
  • Output your diagnostics report (if possible): n/a, RStudio won't even open

From RStudio Desktop Will Not Start on

R works in a terminal session?

R works if I just open up R console, yes

Here's my setup on a 2015 Airbook under Big Sur (can't update OS because aftermarket SSD)

RStudio 2022.07.2+576 "Spotted Wakerobin" Release (e7373ef832b49b2a9b88162cfe7eac5f22c40b34, 2022-09-06) for macOS
Mozilla/5.0 (Macintosh; Intel Mac OS X 11_6_1) AppleWebKit/537.36 (KHTML, like Gecko) QtWebEngine/5.12.10 Chrome/69.0.3497.128 Safari/537.36

> sessionInfo()
R version 4.1.2 (2021-11-01)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Big Sur 11.6.1

Matrix products: default
LAPACK: /Library/Frameworks/R.framework/Versions/4.1/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods  
[7] base     

other attached packages:
[1] tidyr_1.2.1  purrr_0.3.5  dslabs_0.7.4 dplyr_1.0.10

loaded via a namespace (and not attached):
 [1] fansi_1.0.3      withr_2.5.0      assertthat_0.2.1
 [4] utf8_1.2.2       R6_2.5.1         DBI_1.1.3       
 [7] lifecycle_1.0.3  magrittr_2.0.3   pillar_1.8.1    
[10] rlang_1.0.6      cli_3.4.1        rstudioapi_0.14 
[13] ellipsis_0.3.2   vctrs_0.4.2      generics_0.1.3  
[16] tools_4.1.2      glue_1.6.2       compiler_4.1.2  
[19] pkgconfig_2.0.3  tidyselect_1.2.0 tibble_3.1.8    

Can you spot any other differences, aside from packages loaded, of course?

Looks mostly the same? I'm running a newer R and OS (as you note), and packages are different. There is also an extra line under Matrix products for me - I'm not sure what BLAS is?

R version 4.2.2 (2022-10-31)
Platform: x86_64-apple-darwin17.0 (64-bit)
Running under: macOS Monterey 12.6.1

Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/4.2/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats graphics grDevices utils datasets methods base

loaded via a namespace (and not attached):
[1] compiler_4.2.2

OK, thanks. BLAS is fine. Good to have. Out of office now, will check further and let you know in a few hours

Thank you for your time and thoughts about this! I was able to get RStudio working this morning - turns out it was not an issue with R or RStudio, rather a unique situation that arose on my computer when I updated OS.

In short, I'm working on a laptop provided through my employer. When I updated the OS, one of the programs my employer uses had an issue that brought up an error window that I was ignoring while trying to fix this issue. However, it turns out my Mac only displays one error window at a time, so by not making a choice on the first window, I was preventing the next window from appearing, which is the standard "RStudio is downloaded from the internet, do you want to open it" window. Once I took care of the first window it appeared, and when I clicked "Open" RStudio opened fine.

Thanks again for your time!

1 Like

Well, there’s one for the ages! Glad you solved I.

A previous topic had the same hidden window problem. Wish I had remembered it and suggested you check!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.