RStudio does not work ...on opening it, high-level menu options shown with grey screen, and nothing works

I can't get even "About RStudio" under Help to display anything.

I tried the suggestions to reset RStudio's state, as well as to choose software rendering (as opposed to hardware). Neither of these fixed the problem.

What can I do? I have installed the latest version of R after uninstalling an older version. I also uninstalled RStudio and reinstalled it.
I am on Windows 10.
Update: I tried running R outside starts ok, but immediately becomes unresponsive. It is a fresh installation of 4.2.

Try white listing R and RStudio in your Windows Security settings, or any other security software you have running in your system.

If this means adding R to the allowed apps in Windows Defender settings, I have done it, but I still cannot run R. At this point I have uninstalled RStudio, and am trying to get R to run on its own, as that seems to be where the problem is. (Once I get it working, will install RStudio and see if that works)

What else can I do?

I have R version 4.2.2 working fine on its own, both on console and GUI.

I then installed RStudio, but it displays a blank screen. What could be wrong?

1 Like

Hi, what version of RStudio are you trying, and what operating system?

RStudio version is the most recent one RStudio-2022.07.2-576 that I downloaded, and I am on Windows 10

I have exactly the same problem. Just today installed new version of RStudio on windows. R is running fine though.

Please can someone from RStudio /Posit help? Very keen to get this resolved asap!

I uninstalled and reinstalled from RStudio-2022.12.0-353.exe and this time, I do not even see the menu options!

Is there anyone from RStudio that can help?

I have the exact same problem. First time this happens to me.

The solution I found was to install the previous version.

I guess the latest needs some bug fix.

I had earlier installed 2022.07.2-576 and that had given me problems as well. Was it this version that worked for you?

Yes indeed, this version worked for me. Maybe you would need to try an earlier one? I hope posit people can help you there.

Just wanted to say my problem is resolved. Some memory intensive code from a few months ago was causing the RSession to occupy a lot of memory, and RStudio was taking forever to load.
(I still do not understand is how the workspace contained anything even after RStudio and R had both been completely uninstalled, more than once.)

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.