RStudio does not start up, opens a task bar icon but nothing more

Error Information:

Description of issue -
My RStudio crashed after attempting to run a computationally intensive batch of code. I was unable to save my script or exit RStudio, so shut down with Task manager. After this I have been unable to open RStudio, which just opens up an icon on my taskbar but does not open up an actual window.

Attempted steps taken to fix -
Following the troubleshoot file 'RStudio Desktop Will Not Start' where I can, I have:

  • Restarted my computer
  • Removed .Rhistory , .Renviron and .RData files from my drive
  • Reset RStudio by changing the name of the local apps folder
  • Uninstalled and reinstalled R multiple times

After reinstalling an error message would appear on some attempted start-ups - "Fatal error: unable to initialize the JIT"

A potentially connected issue is that my firm has stringent firewalls, and so before this issue started I would have to close a warning saying something similar to "Git.version .exe is not working" - but this did not appear to affect functionality.

Any ideas would be very much appreciated!

System Information:

  • RStudio Desktop v.1.2.1335
  • OS Version: Windows 10
  • R Version: 3.6.1
  • Output your diagnostics report (if possible):

From RStudio Desktop Will Not Start on

Have you tried changing to software rendering?, you can change it by holding the Ctrl key while opening RStudio, then you should see this menu and change the "Rendering Engine" to "Software".

Thanks Andre!

Unfortunately the fatal error message still appears after I've tried opening having changed the rendering engine to software.

We've seen this caused in some cases when a user .Rprofile does things like load or manipulate the set of loaded packages on startup. Do you have such a file on your system?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.