Rstudio does not start "Unable to determine real path of R script"

I am using Fedora 32, I have R (3.5.1 ) within conda. I also compiled R 4.0.0 from source but since I was having another problem with Rstudio I removed this version trying to solve these issues. (With 4.0.0 I couldn't install packages because I got an 'C++11 standard requested but CXX11 is not defined' error, I made the mistake of using --with-x=no during that compiling)

Now I tried to either compile a new version (4.0.1) or get R through yum, but every time I try to reinstall Rstudio I get this error:

Unable to determine real path of R script /home/andrespara/R-4.0.0/bin/R (system error 2 (Folder doesn'exist*))

I removed ~/.config/rstudio ~/.local/share/rstudio ~/.rstudio/ every time I removed/reinstalled Rstudio.

I compiled 4.0.1 with this line (deactivating conda before this avoided the X11 error that I had before)

  ./configure \                                                                                                                                                           
        --prefix=/opt/R/${R_VERSION} \
        --enable-memory-profiling \
        --enable-R-shlib \
        --with-blas \

I added symbolic links following these instructions Posit - Install R from Source - Posit Documentation

sudo ln -s /opt/R/${R_VERSION}/bin/R /usr/local/bin/R
    sudo ln -s /opt/R/${R_VERSION}/bin/Rscript /usr/local/bin/Rscript

R 4.0.1 is now correctly installed, I even used it today and installed some package the only missing link is with Rstudio and its installation that doesn't recognize it.

My question is how to either jump to another version of R working with Rstudio and get rid of that message when Rstudio starts. Thanks for your help.

  • I should add can't even start Rstudio because it still asks for the 'broken version' even when I tried to reinstall it several times.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.