RStudio does not start after a crash

Error Information:

Description of issue - I was using IDE (specifically: installing a package from source) when it suddenly closed. Ever since then I haven't been able to use it. After starting the app the window opens, but it displays nothing but the navigation bar at the top. It is also impossible to close the window using 'close' button, the process needs to be killed from terminal.

Attempted steps taken to fix - I've tried rebooting the laptop. I've tried reinstalling the package from arch repostiory (I was using latest stable available, rstudio-desktop-bin). I've tried backuping all config, tmp and profile files. I've tried hard reinstallation (i.e. with removal of all config files etc.). I've tried building from source, but failed due to some errors in the code.

R from terminal works well, the aforementioned package builds and installs correctly.

I haven't found any crash report.

Attached diagnostics file is after removal of all preferences and config files.

System Information:

  • RStudio Edition: Desktop
  • RStudio Version: 2021.09.2+382
  • OS Version: Linux 5.10.102-1-MANJARO
  • R Version: 4.1.2
  • Output your diagnostics report (if possible): file on gists

From RStudio Desktop Will Not Start on

Okay, nevermind. I haven't tried running RStudio as an administrator. Right now it works. However, I have never needed running it in admin mode.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.