RStudio does not start - 8th Oct 2021

Error Information:

I have been using RStudio for a few years, but for some reason it has stopped working sometime in the last few weeks and I cannot get it to run at all now.

The version I had was 1.4.1717 desktop with R version 4.1
I have tried uninstalling and reinstalling, both with the 1.4.1717 version, and also with the latest version 2021.09.0-350 with the latest R version 4.1.1 x64
I am running Windows 10 with latest updates installed
I have tried to run RStudio diagnostics but there is no output
I have tried holding down the control key when clicking on the program but it makes no difference
I have tried deleting or renaming previous RStudio folders
I have tried resetting my PC to a previous state of a few weeks ago - it still doesn't work
I have tried downloading and installing both R and RStudio onto a different Windows 10 machine - it works fine on the other machine (although I haven't tried to copy across all my packages)
I have tried rebooting my PC with most services and startup tasks disabled - it still doesn't work
I have tried briefly turning off my Windows firewall - it still doesn't work

I cannot find any other information online that is giving me any clues. Please help!

From RStudio Desktop Will Not Start on

Also my R installation runs fine by itself.

Further update: clean booting Windows 10 does not resolve the issue.
I've also tried installing older versions of RStudio - v1.2.5042 also fails to open.
However, the even older version v1.1.463 DOES open.
I have generated and located crash dump reports for other times when the newer RStudio releases
have failed to open in case that will be of use to someone, but not quite sure how to upload those files


Some further info on my edition of Windows:
Windows 10 Pro
Version: 21H1
OS Build: 19043.1266

The issue has possibly arisen after one of the Windows updates in the last few weeks, but I don't know how to try to resolve it. I did try a system restore to a previous time point (24th Sept), but RStudio still wouldn't start up. I have double checked for the latest graphics drivers for my system today and they seem to be up to date.

remove Rstudio version 2021.09.0-350.
install old version RStudio Desktop 1.3.1093: Older Versions of RStudio - RStudio

Thanks for responding, but I have tried that. I've also tried v 1.2.5042. It also does not start up on my PC. I've only been able to get v1.1.463 to work.

1 Like

I had the same problem and i had to go back to the version v1.1.463 , and now it's working, kind of well.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.