RStudio desktop Stopped working after Reboot and will not open, followed Feb 11 Support to no avail

I run RStudio Desktop IDE on my Win 10 machine daily, for nonsense personal projects and messing about. Lately I've been using it to manipulate the serial data logs from a microcontroller into a graph of various data streams. I use it frequently as it's part of the hardware development process for me.

Despite my general unwillingness to update, Windows 10 is somewhat insistent and last night it went through several update cycles and reboots. This morning I am unable to open RStudio, very much to my dismay. I ran through the Desktop troubleshooting article published here Feb 11th, and the Resetting RStudio Desktop's Settings article to no avail. My current code project executes within the R 4.01 terminal without issue.

I've tried downloading and re-installing RStudio Desktop, disabling my A/V, more re-booting, renaming all the .Rprofile and so forth. I'm kind of at my wit's end here. Any help would be greatly appreciated.

Can you provide more detail as to to this point. Does literally nothing happen when you click to start Rstudio (i.e. its as if it was never clicked) , or does something happen, like an, error, warning or some other failure >?

I realized this morning that I didn't leave a very good description of what it does do :slight_smile:

The behaviour is the same whether I use the shortcut in the taskbar or navigate directly to the install folder and click on the rstudio.exe. The blue "thinking" circle comes up next to the cursor for ~ 2 seconds, then disappears and nothing else happens. It's like the "click" gets lost on it's way to execution.

It ~seems~ like it's strictly RStudio that is impacted by whatever is going on. As I noted, I can still run code directly in the RGUI and thus far any other installed app continues to work but not this one.

A summary of actions taken today.

  1. Uninstall RStudio
  2. Log out
  3. Reboot
  4. Download RStudio (even though it's the same file as last night)
  5. Install
  6. Attempt to run
    6.1 Cursor indicates ~ 2 seconds of busy, then nothing
  7. Disable firewall and antivirus
  8. Attempt to run - same results
  9. Using SpaceSniffer, find and rename any and all instances of .Rprofile, .Renviron and .RData
  10. Open RGUI 4.0.1 64 bit
    10.1. Fatal Error: unable to initialize the JIT (awesome - things have gone from bad to worse now).
    11.2. Console window reports Error: package 'compiler' does not have a namespace
    11.3. GUI crashes/closes
  11. Open RGUI 3.6.1 64 bit. GUI opens and runs successfully.
  12. Download and install R 4.0.4 for Windows and install all but 32-bit
  13. Reboot machine
  14. Open RGUI 4.0.4
  15. run recent sketch
  16. All required packages load and sketch executes as expected.
  17. Try RSudio again - no luck, still not starting.

Will continue to pick away at it.

This issue continues but took a very unexpected turn.

It's so strange that of the software I use frequently, it's only affected RStudio.

I woke up the other morning convinced I'd sorted it out. It must be opening on a phantom screen, or it's opening on the laptop screen despite it being closed, but after coffee realized it wasn't showing up in the taskbar, the task switcher or the task manager. Swing! And a miss. :frowning:

The equipment in question comprises a Gigabyte Aero Classic laptop, a Dell D6000 USB-C dock and an LG multiple-input monitor. The laptop sits in a little rack with it's power supplies and dock. The dock connects to the monitor via Display Port out to HDMI in, and is connected to the wired network and numerous USB cables cluttering things up. It's almost never opened, just sits in it's little space and is used via the peripherals (welcome to month 15 of Morbidly Stationary 2020).

I'd conceded defeat, backed everything up, removed the laptop from it's spot and disconnected from the dock. Rebooted to try and catch the recovery screen for a full refresh, but missed the critical millisecond and went to a full boot. There was the RStudio icon staring at me, taunting me. So I clicked it. And suddenly, it worked.

What. The. Hell?

Now what? We test. And test and test and test and discover new tools and information, like the Windows Reliability tool.

2021-03-05 18_14_56-Problem Details
(Other than a couple of specific-incident data points, the failures have the same information. )

I tested the laptop on it's own, connected to the dock and connected directly to the monitor via USB-C as opposed to via dock's display port. I tried multiple combinations of resolutions, scaling, duplicating, extending and assigning "main" status. The results:
The laptop on it's own works exactly as one would hope. It functions flawlessly.

If connected to the dock, the laptop must be open and the laptop screen must be the main monitor, whether it's the laptop only, in duplicated mode or extended mode. The resolution and scaling play no part (as anticipated).

Leaving it connected to the dock (network, peripherals), but driving the monitor via the 2nd USB-C port (on the laptop), it again functions exactly as one would expect. With the laptop screen, without the laptop screen, duplicated, extended, main, sub, whatever you want to throw at it, it works.

So, I have a work-around at least. but it's not a solution. RStudio remains the only program affected, at least in so much as I've tested my "normally used", there may be others that I did not test. It's clearly related to a) the Dell dock and b) the dock display output. Comparing the timelines of Windows driver updates and the sudden failure, there is a definite correlation.

BEX64 is often either a video driver issue, or a USB-driver issue which sort of narrows it down, but not really. the laptop has the latest video drivers and there hasn't been an update in the Dell software for the dock in a long time. I'll keep picking away at it and we'll see what we find. Perhaps it's as simple as rolling back the Windows driver update.

The solution turned out to be straight forward. Just start over from scratch: re-install Windows, re-install R, re-install RStudio. Good times, good times. However here I am with a fully-functional RStudio install so I've got that going for me which is nice.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.