Rstudio Desktop not starting

Hi, I hope someone can help me.
I am using RStudio IDE Desktop and since yesterday morning it was working fine.
After an attempt of training a randomForest (only a few loops) it started to have issues , it went into an infinite loop that it was even difficult to stop the process.
Anyway after managing to stop it, I re-started my Mac several times already, but with no luck.
I am not able to open or start RStudio anymore.
I don't even receive any message from Rstudio, it simply tries to open (all white screen) and suddenly shut-down after a few seconds. No way to understand what's going on on my side.
I also read this post link, but my .Rprofile and .Renviron have been last modified months ago, they did not change.
I am using Mac OS Catalina 10.15.7 (freshly updated) and my R version is 4.0.2, RStudio version 1.3.1073.
If I separately open only the R console it works fine (and apparently no working processes going on).
Hopefully someone can help, thanks in advance

1 Like

I have the exact same issue. I reinstalled both R (4.0.2) and RStudio (version 2021.09.0+351), however, the problem remains.
If I separately open the R console it works fine, but whenever I open RStudio the RStudio window opens (white with the loading sign) and suddenly shuts down after 2-3 seconds.
I've read a bunch of earlier posts, but none of them seem to work for me. I have no idea what else to do now and would greatly appreciate any help!
Thank you in advance!

Hi Desi, yes I also re-installed RStudio like you but with no luck...and since I needed to work I connected Sublime text with the R console.
I might say that except the auto-completion, it's a pleasure to type-in and works even faster.
Hopefully in the meantime someone will understand what's causing this.

Hi Willem, it's good that you found a workaround. I quickly checked out Sublime Text, which looks nice. However, it'll take some time to get used to it and I'd much rather stick to RStudio, for which I know a lot more features atm (In addition, I'm working on different computers and would like to have the same software for all). Thus, I still really want to solve this issue and get RStudio running again on my personal laptop.
I hope someone can help!

@lulu_1 yes definitely who first solve it, should share it :slight_smile:
I was hoping someone from RStudio could have given an indication here, because as far as I read in the RStudio webpage, they'll only provide assistance (answering to emails) only if you have a pro account, not just like the free Desktop version.

I just tried the following and it seems to have worked for me. From kevinushey on this page RStudio Mac OS X 10.15.7 Crashes Everytime - #4 by hender :

It looks like the latest macOS update introduced a driver update that breaks all existing releases of RStudio. See #10020 for more details.

If you need a fix, you can run the following command from the Terminal:

defaults write com.rstudio.desktop 

This will force RStudio to use software rendering. You can try and launch RStudio again after making this change.desktop\xb7renderingEngine' 'software'

This will force RStudio to use software rendering. You can try and launch RStudio again after making this change.

Hope this helps.
1 Like

Wonderful, thank you so so much @OBarton for linking the fix you found! RStudio works perfectly again after trying this :slight_smile:

Hi @OBarton I'm really sorry to come back so late, but I just found the notification was on the spam email!
Thank you so much for the assist, it worked for me immediately!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.