RStudio Desktop : Import Excel Screen can't import data when use Japanese Language sheet name.

I'm facing issues which Import Excel screen can't import data when I use Japanese Language sheet name.
Please let me know how to resolve this issue.

[Current Situation]

  • I want to upload Excel file which contains Japanese sheet name and data using Import Excel Data screen in Environment tab.
  • I can see Japanese file name in "Sheet" and data was showen correctly Japanese text in this screen.
  • However, when I select Japanese sheet name then popup error message raising with garbled Japanese character.
  • Generated R codes in "Code Preview" is works fine.


  • Windows 10
  • RStudio Desktop (Version 1.1.456)
  • sessioninfo()

R version 3.6.2 (2019-12-12)
Platform: x86_64-w64-mingw32/x64 (64-bit)
Running under: Windows >= 8 x64 (build 9200)
Matrix products: default
[1] LC_COLLATE=Japanese_Japan.932 LC_CTYPE=Japanese_Japan.932
[3] LC_MONETARY=Japanese_Japan.932 LC_NUMERIC=C
[5] LC_TIME=Japanese_Japan.932
attached base packages:
[1] stats graphics grDevices utils datasets methods base
loaded via a namespace (and not attached):
[1] compiler_3.6.2 tools_3.6.2 Rcpp_1.0.3 cellranger_1.1.0
[5] readxl_1.3.1

Do you see this issue in RStudio v1.2 (the current release) or in the RStudio preview release?

Hi, @kevinushey.
Thank you for your reply.

OK. I will check v1.2 and release note.
If I have any questions then I will reply this topic.

Best regards.
Thank you.

I made a try importing an Excel file with japanese characters in the sheet names and got the same problem.
You could import the file using the sheet number in the code, like this:

read_excel("C:/Your_path/japanese_test.xlsx", sheet = 2)

Hi, @TomasG
Thank you for your reply.

Yes. I have already checked works fine for R code level.
But in this case, I would like to use UI screen for import Excel file because user is new to R and RStudio.

Could you please share your RStudio Desktop's version?
If you face same issues on same version which I'm using it then it might be resolve upgrade RStudio Desktop Version. (My version is RStudio Desktop (Version 1.1.456))

Best regards.
Thank you.

Hi, @kevinushey
Thank you for your support.

I read v1.2 release note also Issues on Github.
It seems that these release note and Issues resembles to my issues.

[Release note]
-> #1910
[Github Isses]

Could you please let me know if you know these issues was fixed in latest version ?
If these issues was fixed and included latest version then I will start upgrade from 1.1.4 to 1.2 or higher.

Best regards.
Thank you.

@tminoda my current RStudio Desktop version is 1.2.5033.
I also tried with sheet names using other special characters and got the same issue.

To the best of my knowledge, this is fixed in the RStudio v1.3 preview release.

Hi, @TomasG
Thank you for your confirmation.
I understand this version can't resolve my issue...
I will try to use v.1.3 .

Thank you for your support!

Hi, @kevinushey
Thank you for your reply.

Sure. I will try to upgrade my environment to v1.3.
If I have some questions I will update this ticket.

Best regards.
Thank you.

Hi, @kevinushey
Thank you for your waiting.

I updated latest version (Version 1.3.929) to my laptop and try to attempt same import operation previously.
Unfortunately, I faced same issue. We can see Japanese sheet name but when I select Japanese select name in "Sheet" select box then same error happens again.

So could you please tell me what is next step if you have any idea?

Thank you for your help.
Best regards.
Thank you.

Thanks for following up. Would you mind filing this as a bug report at

Thank you for your reply.

I posted bug report at Github issues.

If I have something missed out or misunderstanding then please let me know.

Best regards.
Thank you.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.