RStudio desktop crashing on Mac immediately after launch

Hi everyone,

I have read some similar posts (such as here and here), but I have not yet found a solution to my problem yet.

Description of crash
RStudio keeps immediately crashing when I try to launch the app. Without doing anything, I get this message:

"R encountered a fatal error.
The session was terminated."

Then, after I click "okay" on the fatal error message, I get another message that pops up that just says "null."

As I can't actually use RStudio at all, I can't print the session info or anything like that.

System information
RStudio 1.4.1717
RStudio desktop edition
R version 4.0.5 (2021-03-31) -- "Shake and Throw"
Platform: x86_64-apple-darwin17.0 (64-bit)
macOS Mojave, version 10.14.6

Steps taken to solve the issue
I have basically gone through all of the steps listed here. More specifically:

  1. Check the version of R: see above.
  2. Check for Startup files: I made sure that there weren't any .Rprofile, .Renviron, or .RData in my working directory (or any R Project folders).
  3. RStudio cannot find R: when I type " Sys.which("R") " into the R console, I get " "/usr/local/bin/R" ". I guess that is fine?
  4. Check firewall, proxy settings, and antimalware: This is mostly not applicable, but I did add localhost and to the list of approved Hosts and Domains.
  5. Check the permissions on the ~/.rstudio-desktop directory: I don't really know how to do this and the directions are not clear.
  6. Reset RStudio's state: This initially worked a few weeks ago when I first had this problem. Now, it doesn't seem to work. In the terminal, I get the message "Directory not empty" now.

I have tried to obtain the crash report as described here, but that did not work.

I also tried to deal with potential rendering issues as described here, but again, I have not had any luck so far.

One more detail I will note (in case it is relevant) is that the last thing in the RStudio console that is shown before the crash pop-ups is this:

Registered S3 method overwritten by 'pryr':
method from
print.bytes Rcpp

All of these crashing issues began when I tried to download packages related to rstan and a few other Bayesian packages. Maybe Rcpp was downloaded at that time too? I can't quite remember, but I thought I may as well mention that the instant crashes started after trying to load a suite of packages and their dependencies. At the time, I reset RStudio's state and I didn't load those packages at all and everything seemed fine. Now, the crashes have started again even though I have not tried to load the packages. I was simply using lmer and ggplot, it crashed, and now it keeps crashing.

Any help would be deeply appreciated.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.