RStudio Daily Build Never Loads

I tried to update to the latest RStudio daily (1.2.600), but after installing, it never loads past this screen:

I just get the spinning wheel indefinitely. Is there an additional dependency I need to install on my computer?

The preview version (1.1.446) works perfectly.

System information:
macOS High Sierra (10.13.4)
R version 3.5.0

#> Session info -------------------------------------------------------------
#>  setting  value                       
#>  version  R version 3.5.0 (2018-04-23)
#>  system   x86_64, darwin15.6.0        
#>  ui       X11                         
#>  language (EN)                        
#>  collate  en_US.UTF-8                 
#>  tz       America/Chicago             
#>  date     2018-05-02
#> Packages -----------------------------------------------------------------
#>  package   * version date       source        
#>  backports   1.1.2   2017-12-13 CRAN (R 3.5.0)
#>  base      * 3.5.0   2018-04-24 local         
#>  compiler    3.5.0   2018-04-24 local         
#>  datasets  * 3.5.0   2018-04-24 local         
#>  devtools    1.13.5  2018-02-18 CRAN (R 3.5.0)
#>  digest      0.6.15  2018-01-28 CRAN (R 3.5.0)
#>  evaluate    0.10.1  2017-06-24 CRAN (R 3.5.0)
#>  graphics  * 3.5.0   2018-04-24 local         
#>  grDevices * 3.5.0   2018-04-24 local         
#>  htmltools   0.3.6   2017-04-28 CRAN (R 3.5.0)
#>  knitr       1.20    2018-02-20 CRAN (R 3.5.0)
#>  magrittr    1.5     2014-11-22 CRAN (R 3.5.0)
#>  memoise     1.1.0   2017-04-21 CRAN (R 3.5.0)
#>  methods   * 3.5.0   2018-04-24 local         
#>  Rcpp        0.12.16 2018-03-13 CRAN (R 3.5.0)
#>  rmarkdown   1.9     2018-03-01 CRAN (R 3.5.0)
#>  rprojroot   1.3-2   2018-01-03 CRAN (R 3.5.0)
#>  stats     * 3.5.0   2018-04-24 local         
#>  stringi     1.1.7   2018-03-12 CRAN (R 3.5.0)
#>  stringr     1.3.0   2018-02-19 CRAN (R 3.5.0)
#>  tools       3.5.0   2018-04-24 local         
#>  utils     * 3.5.0   2018-04-24 local         
#>  withr       2.1.2   2018-03-15 CRAN (R 3.5.0)
#>  yaml        2.1.19  2018-05-01 CRAN (R 3.5.0)

Created on 2018-05-02 by the reprex package (v0.2.0).

Update: I have tried using the new preview version, 1.2.679, and I get the same behavior. I have tried removing ~/.rstudio-desktop/ as well as my .Rprofile and .Renviron files as suggested here. Everything still works as expected with version 1.1.453. It's only version that causes this freezing behavior.

I have the same issue on High Sierra. If I close Rstudio and then try opening the same project again it seems to work ok.

Can you please provide us with a diagnostics report?

I can't upload a text file and it appears to exceed the character limit here, so I've put a copy of the diagnostic report here:

The entries in the diagnostic report suggest that you're working on a filesystem where advisory file locks are not supported:

25 Jun 2018 13:02:05 [rsession-jakethompson] ERROR system error 45 (Operation not supported) [lock-file=/Volumes/aai_general/Projects/DLM Secure/Psychometric Procedures & Scripts/Scoring & Reporting/Scripts/.Rproj.user/FE528276/sources/s-A9036879/lock_file]; OCCURRED AT: virtual bool rstudio::core::AdvisoryFileLock::isLocked(const rstudio::core::FilePath &) const /Users/rstudio/rstudio/src/cpp/core/file_lock/AdvisoryFileLock.cpp:85; LOGGED FROM: virtual bool rstudio::core::AdvisoryFileLock::isLocked(const rstudio::core::FilePath &) const /Users/rstudio/rstudio/src/cpp/core/file_lock/AdvisoryFileLock.cpp:87

25 Jun 2018 13:03:14 [rsession-jakethompson] ERROR system error 77 (No locks available); OCCURRED AT: virtual rstudio::core::Error rstudio::core::AdvisoryFileLock::release() /Users/rstudio/rstudio/src/cpp/core/file_lock/AdvisoryFileLock.cpp:153; LOGGED FROM: rstudio::core::Error rstudio::session::source_database::supervisor::detachFromSourceDatabase() /Users/rstudio/rstudio/src/cpp/session/SessionSourceDatabaseSupervisor.cpp:566

25 Jun 2018 14:07:02 [rsession-jakethompson] ERROR system error 6 (Device not configured) [path=/Users/jakethompson/mount-acf/july-topic-guide/ind-fungible-calibration.R]; OCCURRED AT: bool rstudio::core::FilePath::exists() const /Users/rstudio/rstudio/src/cpp/core/FilePath.cpp:325; LOGGED FROM: bool rstudio::core::FilePath::exists() const /Users/rstudio/rstudio/src/cpp/core/FilePath.cpp:325

Is there something special about the volume / mounts you're attempting to use RStudio with? If these are networked filesystems, can you please share details on what kind of networked filesystem you're using, and how they're mounted?

FYI I just posted my diagnostic report to No problems with 1.1.* release versions. Starting with 1.2 this issue came up.

I don't believe there is anything special about the volumes that I'm mounting. I'm in a similar position as @vnijs, where everything works fine for version 1.1., but not version 1.2.. Additionally, on windows this doesn't cause a problem. That is, I'm able to run version 1.2.* just fine on a window machine, mounting to the same network drives.

On my Mac, I'm connecting to the /Volumes/aai_general/ server using an smb mount (i.e., Finder > Go > Network > smb://path_to_network_drive).

The other network drive (called mount-acf), is my connection to a high performance computing cluster. For that, I connect using sshfs. In the terminal:

$ sshfs ~/mount-acf -ovolname=mount-acf

I'm not using network drives at all. Just a plain hard drive on MBP (High Sierra). Same as @wjakethompson, no issues on Windows in VM (Parallels)

@vnijs: unfortunately, the diagnostics report is not particularly illuminating. The latest entries in the report seem to suggest something strange is going on:

26 Jun 2018 18:15:19 [rsession-vnijs] ERROR R SUICIDE: Unexpected exception: vector; LOGGED FROM: void (anonymous namespace)::rSuicide(const std::string &) /Users/vagrant/workspace/IDE/macos/src/cpp/session/SessionMain.cpp:1056

26 Jun 2018 18:15:19 [rsession-vnijs] ERROR Unexpected exception: boost: mutex lock failed in pthread_mutex_lock: Invalid argument; LOGGED FROM: void (anonymous namespace)::rCleanup(bool) /Users/vagrant/workspace/IDE/macos/src/cpp/session/SessionMain.cpp:1138

Does resetting your RStudio state make a difference?


@kevinushey I moved the .rstudio_desktop directory as mentioned in the link you suggested and that seems to have resolved the issue. Rstudio now starts up projects as usual. Nice!

Did something change in how global settings were (re)stored between 1.1.* and 1.2.* perhaps that was causing this issue?

There shouldn't be anything that would cause a project to fail to load. Would you be willing to share your .rstudio-desktop folder so I might try reproducing locally?

Sure. Can I email this somewhere?

You can e-mail me at

I've had this same problem with 1.2.x. I've never been able to open it on my mac as it never gets past the initial loading screen. In earlier versions, I got error messages, but it just never loads.

Today, I completely uninstalled RStudio and R, including the .rstudio-desktop folder, and then tried the 1.2 RStudio preview. Still not opening.

I just ran the diagnostics, output is available here:

Edit: Sorry if terse, happy to provide more details as needed, just let me know what I can do.

Btw, I tried everything listed in the article RStudio Desktop Will Not Start, best I can find is that when starting RStudio from the command line I see this:

$ /Applications/                                                                                                                                            Fri Jun 29 13:29:52 2018
"Uncaught TypeError: Cannot read property 'desktopInfo' of null"

We haven't seen that before -- unfortunately, I'm not sure what could be causing it.

Are you using a CRAN binary of R? I notice that you have an alternate BLAS in use; while I doubt that's the issue it does signal that there might be something unique about your R installation or setup.

I noticed that your diagnostics report contains a personal access token (GITHUB_PAT) -- you might want to take the Gist down just to avoid leaking credentials.

Thanks for following up, as far as I know I haven't installed an alternate BLAS (I think libBlas in Accelerate is standard macOS) and I recently uninstalled everything R and RStudio before re-installing with CRAN binaries, including package directories, preferences, etc.. I do use homebrew but never for R.

How do I choose the standard BLAS, or is there anything else I could try.

And thanks for catching the GitHub PAT, I went through the file before uploading but missed that one.

But I think you do need to do some extra actions to teach R to use Accelerate. For example, by default I see:

> sessionInfo()
R version 3.5.0 (2018-04-23)
Platform: x86_64-apple-darwin15.6.0 (64-bit)
Running under: macOS High Sierra 10.13.5

Matrix products: default
BLAS: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRblas.0.dylib
LAPACK: /Library/Frameworks/R.framework/Versions/3.5/Resources/lib/libRlapack.dylib

[1] en_US.UTF-8/en_US.UTF-8/en_US.UTF-8/C/en_US.UTF-8/en_US.UTF-8

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base

loaded via a namespace (and not attached):
[1] compiler_3.5.0

If you want to change the version of BLAS used by R, you usually have to move some symlinks around, e.g.

cd /Library/Frameworks/R.framework/Resources/lib
ln -sf  /System/Library/Frameworks/Accelerate.framework/Frameworks/vecLib.framework/Versions/Current/libBLAS.dylib libRblas.dylib

All that aside, I'm still not sure what could be leading to this crash on your system. Just to confirm:

  • Does RStudio v1.1 run fine on your machine?
  • What if you open RStudio with e.g. open /Applications/ (Just in case some environment variables or similar are affecting RStudio's startup)
  • Is it possible you have some antivirus software or similar running that might be impeding the launch of RStudio / the child rsession process?

@kevinushey FYI I recently installed 1.1.* again and then back to the preview version and the issue started back up again. Somehow settings in .rstudio from 1.1.* are causing problems when trying to open in 1.2.*