Rstudio crashed and now unable to open it after I ran some demanding lines of code

My Rstudio has been working fine but all of a sudden when I was running some demanding lines of code Rstudio froze. After about 15 seconds it crashed and the program closed. Whenever I try to open it after this happened, it will open to a white semi-transparent window and then the whole monitor goes black and the program closes.
I have looked into the diagnostics report on my C drive and I don't see anything obvious. I do see some "ERROR system error 10053". But there are previous instances of this error before I had this crashing problem. I cannot access studio at all to do any troubleshooting.

Some additional info is I am on windows, I have tried reinstalling Rstudio and R, I have tried to see if antivirus/firewall is the problem but none of these fix it.

1 Like

Have you tried resetting RStudio's state?

I looked into trying to do that but I could only find ways of doing it when you have a terminal/console open in RStudio. I cannot even open the software since it crashes right away. If there is a way of resetting RStudio's state without having RStudio open, that would be helpful.

I think you are misunderstanding the documentation, the commands are meant to be run in Windows not in RStudio, for example:

You can open an Explorer window into the RStudio-Desktop directory by typing the following command into Start -> Run:


Yeah so I reset RStudio's state but it did not fix the problem. Rstudio is still not opening up, just crashing. I even looked back at the appdata and it created another folder when it realized I had renamed it and couldn't find it. So I know that I did that correctly.

Have you also reset the other configuration file?


Another thing to try is to delete any .Rdata file present in your default working directory (which will clear your working environment).

Just an update on my RStudio.

I did all those things you mentioned and it did not seem to help at all. I opened it today though and it worked. I had just left it alone for a while. Not sure why it was not working for so long and then just decided to start working randomly. Thank you for your help!

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.