Rstudio Crash fatal error link to rstudio::r::exec::executeSafely and Jenkins

I am using the newest version of RStudio (1.2.1335, downloaded from the Rstudio website) on my Ubuntu (18.04) machine.
It used to work but at some point I got the following error and now RStudio won't start anymore:

The R session had a fatal error.

ERROR r error 4 (R code execution error) [errormsg=Error: option error has NULL value
]; OCCURRED AT: rstudio::core::Error rstudio::r::exec::executeSafely(rstudio_boost::function<void()>) /var/lib/jenkins/workspace/IDE_open-source-pipeline_v1.2/src/cpp/r/RExec.cpp:224

Note that I do not have Jenkins installed on my machine, i.e., /var/lib/jenkins/ does not exist.
Re-installing RStudio does not help either.
The system is otherwise up to date (sudo apt update && sudo apt upgrade).

Any ideas how to fix this issue?

1 Like

On Ubuntu 18.10 cosmic I noticed that R got upgraded to version 3.6.0 today through the CRAN package repo. I was able to get Rstudio running again by downgrading to R 3.5.3:

sudo apt-get install r-base=3.5.3-1cosmic r-recommended=3.5.3-1cosmic

Thanks for the hint. I tried downgrading to 3.5.3-1bionic as I use 18.04 not 18.10. But that didn't resolve the issue.
Downgrading RStudio to 1.1.463 doesn't help either.

Found the error. I had this in my .Rprofile

	error = quote(rlang::entrace()),
	rlang__backtrace_on_error = "collapse"

which worked before but deleting the file resolved the issue.

Thanks @DavZim, removing error = quote(rlang::entrace()) resolved the issue for me!

1 Like

It seems this is an RStudio issue, I can reproduce the crash with rlang entrace but also with this simpler reprex:

options(error = quote(print("foo")))

This is fixed in the dev version:

1 Like

I'm on Arch Linux (installed via Antergos) I didn't have any issues when I upgraded to R 3.6.0, but when I updated to rstudio-preview Version 1.2.1511 I got this error.

I ended up commenting out this section in my .RProfile

#if (requireNamespace("rlang", quietly = TRUE)) {
#  options(error = rlang::entrace)

Yep I can confirm I am setting an error function in my .Rprofile as well:

options(error = function() traceback(3))

Commenting it out worked around the issue, I haven't tried the dev version yet.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.