RStudio console extremely slow

For some strange reason, running commands in the RStudio console has become extremely slow. I've found similar topics and none of the solutions mentioned worked for me. Let me start at the beginning. I have downloaded the following publicly available data:

The file is slightly large (100MB) but you'll hopefully be able to reproduce the issue in your system.

Here are the commands I'm running:

my_data <- read.csv("Downloads/gwas_catalog_v1.0.2-associations_e96_r2019-08-24.tsv", sep = '\t')[,-c(1,3,4,5,6,7)]

sp_data <- split(my_data, my_data$PUBMEDID)

When the second command finishes, pressing Enter again or inputting another command, say length(sp_data), blocks the console as if the previous command is still running.

I'm using RStudio v1.2.1335 on Mac. According to the posts I've found, I've tried resetting the RStudio's state, disabled Showing diagnostics for R and disabled showing the last cursor position when opening file but nothing worked. Please note that these commands work as expected on a normal Mac terminal.

I would have added a request log screenshot but RStudio doesn't let me; pressing the Ctrl+` shortcut doesnt' do anything. Please let me know if you need any more information.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.