Rstudio console delays display of last inputed symbol

I use RStudio Desktop on Ubuntu 20.4 installed by 'sudo gdebi rstudio-1.4.1106-amd64.deb'.

When I press any symbol key on keyboard with active console expected symbol does not appeared, but does appeared symbol inputed before. Like: Console clear now when I press 's' key and nothing appeared. But when I press key 'a' it appears symbol 's' pressed before but not 'a'. Then I press other one, for example, 'p' and 'a' appears. After I press 'Enter' it appears all pressed symbols 'sap' and R interpreter recognizes it normally giving me the expected result. Problem is in that I can't write code normally in console due to not seeing all actual text. I guess problem in something like stack shift or alike. For example when I press 'Backspace' at first, it appears last pressed symbol and when I press this key second time, the symbol previously appeared disappears. When I wrote some text and then hold 'Backspace' all symbols erased excepting first one. If I press 'Backspace' again it doesn't disappear, and again press and this last symbol still here. Equal situation with 'Del' key. And when I press left/right arrows it works similar. It really looks like Console shows me previous state, not following.

What I was doing before problem:
I have been using RStudio for about 1-2 weeks. It worked normally. Today I tried to implement readline() analogue which would work both through 'Rscript' command (from terminal to be interpreted) and in interactive mode. I used function interactive() to recognize whether script run in interactive.
I called both readline() and readLines(con='stdin', n=1) from Rstudio console and using 'Rscript' command in terminal to run my script. When I run script via 'Rscript' command with readline function it returned me "" (empty string). My solution was to get function implementing readline() behavior both in interactive and interpreter modes.
It works fine, but after I solved my issue with readline I found mentioned problem. I can't say exactly how to reproduce this problem.

How I tried to fix it:
I write You because I have no view how to explain it correctly and Google-understandably. I was searching for same problems but didn't found nothing similar. And also I tried few times to reinstall RStudio, but I new to Ubuntu and all my RStudio configurations are saved when I uninstall and then install again Rstudio Desktop (After installation I see the same theme as I set). Once I tried to delete all files with word 'rstudio' in name after deinstallation. I wouldn't write You if it worked.

God damn, it seems I fixed this issue. I removed RStudio and then deleted many trash. At first I set option 'Show Hidden Files' in menu appearing after click on triple line near button "roll up" in 'Files' program. Than I deleted following folders and files in home directory: folder '.r', '.Rhistory' and '.RData'(may not be principal), '.profile' and also from subdirectory '.config' next folders: 'RStudio' and 'rstudio'. After that I installed RStudio again and found out that icon size was different while opening and on open no theme I set before. Also I saw last opened files I was working with before problem occured. I hope You never meet such problems.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.