RStudio Connect sevice needs restart after server is restarted

Our RStudio Connect server is connected to an external Postgres db. The instance stops after hours and starts before hours. We get 502 - Bad Gateway after the instance starts up.
We can recover by restarting the connect through "systemctl restart rstudio-connect".
We are wondering if this is the expected behaviour.
If so, what do you recommend to be the best way to automatically restart after the instance come online?
Thank you.

Hello! Thanks for reaching out! If you continue to run into issues here, this is definitely something you can reach out to our professional support team about -

In any case, there are a few things to keep in mind here:

  • One, you want to be sure that the rstudio-connect service is "enabled." This means it will start on reboot of the server. You can ensure this with systemctl enable rstudio-connect.
  • After rebooting the instance, you should check the status of Connect before "starting it." systemctl status rstudio-connect. That will be useful information as it can tell us why Connect is not starting
  • If you do reach out to our support team, please include your /var/log/rstudio-connect.log file (at a minimum), and ideally your entire diagnostics file:

I hope that helps! Please let us know how this goes!!

Thank you Cole. Will follow your suggestion and reach out to the support.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.