Rstudio-connect deploy failure Error in dyn.load(file, DLLpath = DLLpath, ...)

My shiny app deploys without error to shinyapps and works perfectly. Deploying to an rsconnect account has been a nightmare. It finally deployed yesterday, but there was an error in the code, so I fixed it and attempted to redploy. Now, deployment fails with this message, seemingly related to minqa, lme4 packages:

Error in dyn.load(file, DLLpath = DLLpath, ...) : 
  unable to load shared object '/opt/rstudio-connect/mnt/packrat/4.0.0/v2/library/minqa/a2fe2d2954e0ed209c92412f3677c8f5/minqa/libs/':
  /lib64/ version `GLIBC_2.29' not found (required by /opt/rstudio-connect/mnt/packrat/4.0.0/v2/library/minqa/a2fe2d2954e0ed209c92412f3677c8f5/minqa/libs/
Calls: <Anonymous> ... asNamespace -> loadNamespace -> library.dynam -> dyn.load
Execution halted
ERROR: lazy loading failed for package ‘lme4’

This thread documents a similar error but in shinyapps. Any potential solutions for Rstudio-connect?

This seems like a binary incompatibility. E.g. you installed binary packages that were builds for a different platform.

rsconnect/packrat identified the dependencies in my shiny app and then attempted to install them when I tried to publish the app. This process worked yesterday but not today. I didn't manually install anything.

Yes, sorry, what I meant is that connect is installing binary packages that are incompatible with a the platform. So this might very well be a server side issue, that you can report to your Connect support.