RStudio code execution stops at any random line and never completes execution

I have RStudio Version 1.2.1335 installed on Windows 10 pro 64 bit desktop. Code execution stops at any random line and the execution never recovers again. I have to forcibly close RStudio using task manager. I have tried uninstalling and installing again RStudio but the problem is still there.


Is this happening in any of your scripts, or on one particular? Does this also happen when you run code line by line?

If you can give us a reproducible example, that would be great:

Thank you for the response @pieterjanvc
I have tried many other scripts, still have the same issue. Sorry I cannot share the scripts here because the scripts are on client machine with no internet access. The scripts I tried do basic task of reading data from csv and database and perform join, I also tried a script which build a simple linear regression model. The execution stops at any line, sometimes even at a commented line. I am able to execute the code line by line only, if I run the entire script then the objects never show up in the object explorer.

Hi @sharvina! A few more questions to try to narrow down what might be going on...

What happens if you try a script that uses only built-in data? For example:

tmp <- tempfile()
write.csv(mtcars, tmp)

more_cars <- read.csv(tmp)

lm(mpg ~ cyl + disp, data = more_cars)

How are you running the script? What happens if you use source() to run a saved script file from the console?

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.