RStudio cannot detect Git

Hello, everyone. I am frustrating with using Git in RStudio.

Here are my steps:

  1. I installed the latest version of Git in my Windows
  2. I added C:\Program Files\Git\bin\git.exe and C:\Program Files\Git\cmd into my system path.
  3. I also specified C:/Program Files/Git/bin/git.exe in Git executive under Global Options of Git/SVN.

However, when I tried to user Version Control to create a new project, the warning message below still occurred showing my RStudio doesn't detect Git. And I am sure Git on my Windows worked, because using cmd, Git Bash, VS Code terminal, or powershell, I was able to clone my repository from GitHub to my local machine.

Any advice for this issue is appreciated. Thank you!

1 Like

Hello, I'm in th same situation. I did all recommanded actions, restarted multiple times Rstudio. I even uninstalled Git, Rstudio and R, and reinstalled them but that doesn't solve it.
Rstudio Version 1.4.1103
Windows 10.

Thank you in advance for your help

In order to give more details. Here is what i have when i run "env|grep PATH" on git Bash' terminal in Rstudio.

RS_RPOSTBACK_PATH=C:/Program Files/RStudio/bin/rpostback
EXEPATH=C:\Program Files\Git\bin

So everything seems Ok but when i try to create a new project in Rstudio, I don't have the check box for initiating GIT.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.