RStudio Build Pane and devtools::check() give different checks

I removed some function and tests from my package.

  1. If I run devtools::check(), I do not get any issues with the package. However, if I press the Check button in the Build pane in RStudio, it appears to be searching for the removed tests, and gives an error.

  2. To further explore the problem, I removed the total tests directory. If I run devtools::test(), it correctly states that there are no tests. Yet the build pane is still looking for the tests that erred last time, but not for the tests that ran without error, although both are removed.

  3. Furthermore, I had a wrong function that I removed, but it keeps throwing errors. I tried to remove the .Rproj.user file, the .Rhistory file, but the problem persists, even if I restart the session, etc.

  4. Then I re-created the tests directory with devtools::use_testthat() and placed back the correct tests, which run in the console without error, warning, or note.

  5. The building pane keeps crashing.

  6. In the meantime, on Travis (obviously on a different platform) everything runs without error, warning or note.

I am very puzzled, I keep getting this error since yesterday I updated to R 3.5 and RStudio Version 1.1.447 on Windows 10. Of course, I'd love to provide a reproducible error, but I am puzzled and do not know how.