RStudio Breaks down immediately after updating to 4.1.3

SOS Please help!

I have been using R for quite some time and it was running very well until today.

Today I updated the R version to 4.1.3 , then when I reopened my Rmarkdown file and run it, RStudio encounters Fatal error:Unexpected exception:bad allocation, followed by R Session Aborted pop-up asked to start NEW Session.

I have tried many times to try to solve the error including turn on/off RStudio as well as the compute, I have also uninstalled and reinstalled the R and RStudio, but no help.

Now I try tidyverse, when I ran the tidyverse on R Script, RStudio encounters fatal abortion. But, I reopened the RStudio and ran it again, it shows following error.

Error: package or namespace load failed for ‘tidyverse’ in loadNamespace(i, c(lib.loc, .libPaths()), versionCheck = vI[[i]]):
namespace ‘rlang’ 0.4.11 is already loaded, but >= 1.0.1 is required

I have actually tried numerous times with different packages, and this errors have been popping up. I have also tried to find solutions online, but I couldn't find any.

Somebody please help..


I found the solution myself recording here for others. I just needed to update rlang and xfun, run following codes. Note: Close the RStudio and open it again so other packages wouldn't mask these updates.

file.edit(file.path("~", ".Rprofile"))

The problem has been solved magically.

1 Like

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.