Rstudio blank upon opening (doesn't work when at home)

Hi. When I open RStudio the application appears empty. I can see the menu buttons, but can't interact with them, and I can't see the console or anything else. I believe it is an internet problem, because Rstudio works when I'm on campus just not at home. I made sure to allow rstudio.exe access through my firewall, but this didn't change anything. I'd appreciate any help to figure out what is causing this problem. I ran diagnostics if that helps:

Do you have any better luck with the preview release?

Hi Kevin. I tried the preview release, but unfortunately it still doesn't work. I still believe this is an internet problem, but I've noticed that even though it is blank upon opening it continuously increases its RAM used when open.

Just to confirm, is it the RStudio process consuming memory, or RStudio R Session?

You might also try resetting RStudio's state:

Are you working with files / packages located on a networked filesystem or anything like that?

I think I made progress as to why it takes up so much memory! When I went into Task Manager and clicked on the little arrow so I could see which processes were running with RStudio I saw that RStudio kept creating "git for windows" processes which rapidly took up a lot of memory. This must surely be related to the problem, right?

To answer your questions, I have tried resetting RStudio's state and I'm not working with files/packages located on a networked filesystem.

That's surprising -- this does sound like an issue that should've been fixed in the preview release; see

To confirm whether you might be bumping into the same issue: in your folder, are the .Rproj.user and .git folders hidden folders? Or are they regular visible folders?

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.