Rstudio asking to save something on startup, failing to launch

Rstudio is suddenly failing to launch and is instead prompting me to save an unknown file. I've tried using different versions as well as uninstalling and reinstalling Anaconda, nothing has worked. Has anyone encountered a similar problem and solved it?

This person had the same problem:

Their solution was to switch to using RStudio IDE downloaded directly from RStudio’s site. I’m afraid It’s still not clear where the source of the problem lies.


Having the same problem here. It may be of interest pointing that, in my case, the strange behavior started after a Windows 10 update [scary music plays].

1 Like

:scream: I think that came up in a Stack Overflow post about this phenomenon, but I don’t know if the connection has been verified yet. It’s a bit odd that so far this is only cropping up for people who installed RStudio Desktop via anaconda.

anaconda is distributing an out of date version of RStudio Desktop (1.1.423 vs 1.1.453), so I guess it’s possible there is an incompatibility between that older release and a recent Windows 10 update — and maybe people who installed the older version directly and haven’t updated just haven’t turned up here yet?

Alternatively, I wonder whether it could be related to this known bug (but the problem behavior is not identical):

1 Like

Hello, i have the same problem, I did the windows update. I read from jcblum that it was necessary download directly RStudio's site but i use the package keras which need a virtual environment, that why i use anaconda. The post is from May 22, 2018, Is there a solution now ? Or can i link a Rstudio's site with anaconda ?

The Keras R package on Windows requires a conda environment into which to install the Python components, but this has nothing to do with the RStudio IDE (see: FAQ: What’s the difference between R and RStudio?).

The RStudio IDE does not install R for you — but if you’ve installed R for Windows according to the usual methods, then the RStudio IDE will interact with that installation of R. Similarly, if you have installed Anaconda according to the usual methods, the Keras R package (which you install using R) should be able to find what it needs without any trouble.

So the supported default sequence is:

  1. Install R for Windows (and RTools) from CRAN
  2. Install the RStudio IDE from RStudio
  3. Install Anaconda 3.x for Windows
  4. From the R console, run install.packages("devtools")
  5. From the R console, run devtools::install_github("rstudio/keras")
  6. From the R console, run:

If you’re concerned about the details of any of this, or want a non-default Keras setup (e.g., GPU installation), take a look at the R Keras installation documentation.

If after that you still have questions, it’s probably best to start a new topic (you can link new topics to old ones: at the bottom of this topic, click the Share button, then click + New Topic in the little popup that appears), and be sure to add the #keras tag.

1 Like