Rstudio app inquiry


I am trying to complete an assignment through the Rstudio app.

For this assignment, I must install "RGTk2" and "rattle,” although every time I attempt to do so, I receive an error. I also tried following the instructions in the link, but there was still a failure.

Warning in install.packages :

package ‘RGTk2' is not available for this version of R

A version of this package for your version of R might be available elsewhere,

see the ideas at

Thank you

You can see from its CRAN page that this package has been archived as it's orphaned. What this means is, since 2021, no one is officially in charge of it and updating it. CRAN doesn't like that (someone has to answer emails and keep packages working on new versions of R).

So my first recommendation would be to avoid using a package that is no longer maintained, as you risk running into more problems. Since it's an assignment, you might want to point this out to the teacher (they might have a local install that they haven't tried to update in a while and is still working).

If you still want to try installing it, you can use remotes::install_version() to install the last working version from the CRAN archives. It should be version However, as you can see here, there is a chance that this installation will fail, and would require some advance knowledge to get it to work.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.