Rstudio and libclang disappeared in Ubuntu 18.04.03

Hi everyone

as unbelievable as it sounds this is exactly what happened.
Last week I installed rstudio and r as well as most packages that I use in a brand new dell laptop.
Today, I tried to open rstudio and it did NOT exist, it simply vanished! For a moment I thought I was going crazy but then I looked in my downloads and I noticed that I had indeed downloaded a week ago the latest rstudio as the deb file was in my downloads. Tried to install but here is what I get:

dpkg: dependency problems prevent configuration of rstudio:
rstudio depends on libclang-dev; however:
Package libclang-dev is not installed.

Tried to install with sudo apt but then there are some other unmet dependencies including lib32gcc1 and libc6-i386.
Long story short, I managed to install it by first installing the libc6-i386, then the lib32gcc1 and then the libclang crap. Then rstudio got installed.

However this has never happened to me before (a fresh new install of Rstudio and dependencies dissapearing) and I am worried that this may happen in the future - so I d like to hear if other people have experienced sth similar.

and happy friday

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.