Rstudio 2023.12.1 does not reach Rtools 4.4

Dear all,

After updating RStudio and Rtools I got this


Here is my configuration:

  • Windows 10
  • RStudio 2023.12.1
  • R version 4.3.3
  • RTools 4.4
  • Path : C:\rtools44\usr\bin

I have tried many options (uninstall/reinstall, change versions, change path, black magic incantation...), nothing has worked.

Any help is very welcome!



From CRAN: "Rtools44 is currently used for R-devel, the development version of R, to become R 4.4.0." Use RTools 4.3 with R 4.3.x

R 4.4.0 has not been released yet. A beta version was made available a few days ago and a release version is scheduled for April 24.

No... cannot be so obvious ! But it works ! Many thanks ! I tried with Rtools 4.2 but unsuccessfully. I don't understand why it works with Rtool 4.3 but nevermind.

Generally its best to match the Rtools version should be matched to the R version eg R 4.3.x <-> Rtools 4.3, R 4.2.x <-> Rtools 4.2, etc.

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.

If you have a query related to it or one of the replies, start a new topic and refer back with a link.