RStudio 1.5.1 on Ubuntu 18.10 -- "cannot execute binary file: Exec format error"

I just tried upgrading RStudio to 1.2.5 on Ubuntu 18.10. I downloaded the .deb file from

Then I run sudo gdebi rstudio-1.2.5001-amd64.deb

The installation completes with no errors. But I get a strange error when trying to start rstudio:

bash: /usr/bin/rstudio: cannot execute binary file: Exec format error

(base) balter@spectre:~$ sudo gdebi rstudio-1.2.5001-amd64.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done

 RStudio is a set of integrated tools designed to help you be more productive with R. It includes a console, syntax-highlighting editor that supports direct code execution, as well as tools for plotting, history, and workspace management.
Do you want to install the software package? [y/N]:y
(Reading database ... 136307 files and directories currently installed.)
Preparing to unpack rstudio-1.2.5001-amd64.deb ...
Unpacking rstudio (1.2.5001) over (1.2.5001) ...
kSetting up rstudio (1.2.5001) ...
Processing triggers for mime-support (3.60ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.17-2) ...
Processing triggers for shared-mime-info (1.10-1) ...
(base) balter@spectre:~$ which rstudio
(base) balter@spectre:~$ rstudio
bash: /usr/bin/rstudio: cannot execute binary file: Exec format error

This topic was automatically closed 21 days after the last reply. New replies are no longer allowed.