RStudio 1.2 cannot open or save any file

Hi all,

I am an (Arch)Linux user and I updated RStudio to version 1.2, to be able to try the Jobs tab.
Unfortunately, I cannot open or save any script/file (5: Error occurred while executing method\n2: [system] No such file or directory), unless I run RStudio as root, as suggested in this thread.

However, when I downgrade RStudio to 1.1, this problem does not occur.
I tried to reset my preferences by rename the ~/.rstudio-desktop directory.
I tried to open/save a file directly in my home folder.
I tried to open/save a file in a directory with all permissions granted to everyone (-rwxrwxrwx).
Nothing worked.

Here are some more info:

  • System: Archlinux release 5.1.4-arch1-1-ARCH
  • RStudio version 1.2.1335, downloaded and installed from AUR
  • sessionInfo():
R version 3.6.0 (2019-04-26)
Platform: x86_64-pc-linux-gnu (64-bit)
Running under: Arch Linux

Matrix products: default
BLAS:   /usr/lib/
LAPACK: /usr/lib/

 [1] LC_CTYPE=en_US.UTF-8       LC_NUMERIC=C               LC_TIME=en_US.UTF-8        LC_COLLATE=en_US.UTF-8    
 [5] LC_MONETARY=en_US.UTF-8    LC_MESSAGES=en_US.UTF-8    LC_PAPER=en_US.UTF-8       LC_NAME=C                 

attached base packages:
[1] stats     graphics  grDevices utils     datasets  methods   base     

Any idea of what's going wrong?

Do you see any other diagnostic output in the system error logs?

In ~/.rstudio-desktop/rsession-USERNAME.log or in ~/.rstudio-desktop/rdesktop.log, nothing is written when the error happens.

The error appears as a dialog window: No such file or directory, and also in the command line when RStudio is launched from it: "5: Error occurred while executing method\n2: [system] No such file or directory".

Where else could I check for system logs?

Quick update:

When I want to create a new project, from an existing directory, the path that is shown in the New project window seems correct for version 1.1. For versions 1.2.1335 and 1.2.1522 (still in the Archlinux AUR packages), the path is wrong:

What is the output of:


on your machine? Did you do anything to explicitly customize this environment variable?

Oooh, indeed. Here is the output:

> path.expand("~/")
[1] "/home/ewen//"
> Sys.getenv("HOME")
[1] "/home/ewen/"

I don't know where does the trailing / come from in the $HOME environment variable. I edited my /etc/passwd file to remove this slash, and now everything works perfectly!

Thanks a lot @kevinushey :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.